Creating and implementing a notification plugin

Notifications can be set to alert you if a job is successful, unsuccessful, or either result. Additionally, a notification can also indicate if a job was launched
from the Workbench or from a command line, and can produce a report in a number of different file formats.

You can select the following options and option parameters using the job notification plugin:

Notification Option Option Parameters

Notify When Run From
® Workbench
® Command Line
® Both

Attached Report

None
CSsv
XML
HTML

RTF

Send Notification
* Always
® Only on Success
® Only on Failure

Notification parameters are set independently on each job configured in DB Change Manager. Additionally, each set of notification options apply
individually per job selected.

The notification plugin must be defined in Eclipse and then activated in DB Change Manager. The following tasks provide a high-level overview of defining
and implementing the notification plugin:

Create a plugin project

Configure the target platform

Define dependencies

Implement a notifier class

Implement a viewer contribution

Specify setup constants

Implement the DirectoryNotifier class

Implement the DirectoryNotifierContribution class
Register the extensions

Deploy the Notifier plugin

Create a plugin project
In order to start building a plugin, you need to create a new plugin platform in Eclipse.
To create a plugin project

1. Select File > New > Other.
The Select a Wizard dialog appears.
. Select Plugin Project, and then click Next.
Type a name for the plugin in the appropriate field, and leave the remainder of the parameters as they appear.
. Click Next.
. Retain the default parameters on the next dialog, and then click Finish.
The new plugin project is created in Eclipse and is ready for plugin development.
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Configure the target platform

The target platform for the plugin development process needs to be identified in DB Change Manager. This indicates to the new plugin for what product it
extends, and grants the plugin access to the system.

To configure the target platform

1. Select Window > Preferences.
The Preferences dialog appears.
2. Choose the Plugin Development > Target Platform node, and then click Browse.
3. Navigate to the install directory for DB Change Manager.
4. Click Apply, and then click OK.
The Preferences dialog closes and the target platform of the plugin is now indicated.



Define dependencies

The new plugin requires a pair of dependency definitions on the DB Change Manager Notification plugin:

® comidera. change. notifications
® org.eclipse.ui.forms

1. Navigate to the META- | NF folder in your project and double-click MANI FEST. MF.
The MANI FEST. M file opens in Eclipse.
2. Select the Dependencies tab, and then click Add.
3. Choose com i der a. change. noti fi cati ons, and then click OK.
The dependency is added.
4. Choose org. ecl i pse. ui . f or ns, and then click OK.
The dependency is added.
5. Press Ctrl+S to save the changes; or choose File>Save from the menu to retain the new dependencies, and then close the editor.

Implement a notifier class

Each natification plugin requires a Not i f i er class that must implement the interface com i der a. change. noti ficati ons. api .| Notifier.Todo
this, you subclass com i der a. change. noti fi cati ons. api . Abstract Noti fi er and customize it.

If Abstract Notifier orlNotifier cannotbe found in Eclipse, the target platform or plugin dependencies are not configured properly.
Ensure that you have configured these prerequisites and then search again for the notifier classes.

To implement a notifier class

1. Right-click on your project, and then select New > Class.
The New Java Class dialog appears.

. Java Class

Create 2 new Java class,

Source folder org.acme.directorynotifies/src

Package: org.acme.directorynotifier

Mame: Directorytlotifier
Medifiers: @ public ) default profected
[ abstract [ fina]

Superclass: com.embarcadero.changenotifications.api.AbstractMotifier

Interfaces:

Which method stubs would you like to create?
[7] public static void main(String[] args)
[ Constructors from superclass
[#]Inherited abstract methods

Do you want to add comments as configured in the properties of the current project?

2. Enter the appropriate information in the fields provided to define the new Java class:



a. In the Name field, type "DirectoryNotifier".

b. In the Package field, type "org.acme.directorynotifier".

c. Inthe Superclass field, type "com.idera.change.notifications.api.AbstractNotifier".
3. Click Finish to create the new class.

Once you have defined the Di rect oryNot i fi er class, two methods require implementation:

® i sReport Support ed returns a Boolean value indicating if the notification can include a report. The directory notifier returns true, because
reports can be replaced in a directory, but a notification may not support reports. This method is called when creating job editors to determine if
the reporting section is shown for this type of notification.

* sendNoti ficati onis called after a job runs and is responsible for the notification. The three parameters are as follows:

Parameter Type Description
notifierData @ iNotifierData This instance contains the configuration for the notification of the job just run.
j obMet aDat a Map<String, This map contains information about the job execution. The keys in the map correspond to entries in the
String> NotificationPropertyEnum.

For example, to get the data and time of the execution, you would code:
"jobMetaData.get(NotificationPropertyEnum.DATE_TIME.getTag())"

NOTE: The keys are the tag of the enum entries, so ensure that getTag() is called when accessing
jobMetaData.

notification @ iReportGenerat Used to generate the report and access any DDL or sync script output.
I nfo or

Implement a viewer contribution

Each notifier can be configured for a job in DB Change Manager.

The notifier enables a user to select a target directory in which to put results. The email notifier that is supplied with the application enables users to select
the email template that will be used to generate the message as well as the addresses of those who will receive it.

In order to add a directory field to the job editor, you write a class that implements the interface named com i der a. change. noti fi cati ons. api .
I NotifierViewerContribution.

® Create a new class named "DirectoryNotifierViewerContribution" and follow the same steps you used to create the Di r ect or yNot i fi er class.

The exception to this process is that you need to leave the Superclass parameter set to "java.lang.Object", as well as adding the interface | Not i f
i erViewerContribution tothe list ofimplemented interfaces.

Specify setup constants
The notifier only allows users to select a directory in which reports and outcomes are written whenever jobs are executed.
The DirectoryNoti fi er Constants class is a small constants class that stores the property name for storage and retrieval purposes.

1. Create a new class named Di rect oryNoti fi er Const ants.
2. Enter the following code for the class definition:

/**

* Const ant sfort hi snet wor ksharenotifier

*/

publicfinal cl assDirectoryNotifi erConstants

{

/1 Qverviewfilename publicstatisfinal Stri ng OVERVI EW FI LE_NAME="out cone. txt";
/] Persi stedJobSettingsKey publicstatisfinal STri ngTARGET_DI RECTORY="di rectorynotifier.

targetdir"”;

/**

* Constantutilityclasscannotbeinstanti ated

*/

privateDirectoryNotifierConstants()

{

}
}

Implement the DirectoryNotifier class
The DirectoryNotifier classcan be coded with two return methods:

® i sReport Supported
® SendNotification



To implement the i sReport Supported method
® Enter the following code:

public bool ean i sReport Supported()
{

}

To implement the SendNot i fi cati on method

return true,

1. Toaddthe notifierProperties andassignthetargetDi rectory toa variable to provide a directory that the user selected for the
executed job, add the following code:
public void sendNotification (INotifierData notifierData, Map<String, String> jobMetaData,
notificationlnfo
Map<String, String> notifierProperties = notifierData.getNotificationProperties();
String targetDirectory = notifierProperties.get (DirectoryNotifierConstants. TARGET_DI RECTORY);
2. Enter the following code to define that the report and output file need to be placed in a directory whose name is composed of the job execution
date and time.

@ If a directory cannot be created, the code below also includes a Runt i meExcepti on.

//Create a new directory naned by the execution date and tine
String dateTinme = jobMetaData.get (NotificationPropertyEnum DATE_ TI ME. get Tag() );
File dir = new File (targetDirectory + File.seperatorChar + dateTine.replace ( ':', '-' ) );
bool ean createdDirectory = dir.nkdir();
if (!createdDirectory )
{
throw new Runti meException ("Create Failed: " + dir.getAbsolutePath () );

3. Enter the following code to define the outcome file, which includes each of the job execution parameters:
try
{
//Wite the results to an output file
File f = new File (dir.getAbsolutePath() + File.seperatorChar +
Di rectoryNotifierConstants. OVERVI EW FI LE_NAME ) ;
f.createNewFl | e();

BufferedWiter witer = new BufferedWiter (new FileWiter (f) );
String newLine = SystemgetProperty ("line.seperator");
witer.wite ("Qutconme: " + jobMetaDAta. get
(NotificationPropertyEnum JOB_OUTCOVE. get Tag() ) + newLine);
witer.wite (newLine);
witer.wite ("Date & TineL" + jobMetaData.get (
Noti fi cati onPropertyEnum DATE_TI ME. get Tag() ) + newlLi ne);
witer.wite ("Elapsed Tinme: " + |jobMetaData.get (
Noti fi cati onPropertyEnum ELAPSED_TI ME. get Tag() ) + newLine);
witer.wite newLine );
witer.wite ("Name: " + jobMetaDAta.get (
Noti fi cati onPropertyEnum JOB_NAME. get Tag() ) + newLine);
witer.wite (newLine);
witer.wite ("Host: " + jobMetabData.get (
Noti fi cati onPropertyEnum JOB_HOST. get Tag() ) + newli ne);
witer.wite ("Job Type: " + jobMetaData.get (
Noti fi cati onPropertyEnum JOB_TYPE. get Tag() ) _ newline);
witer.wite ("Mdule: " + jobMetaData.get (
Noti fi cati onPropertyEnum MODULE. get Tag() ) + newLine);
witer.wite (newLine);
witer.wite ("Sources: " + jobMetabData.get (
Noti fi cati onPropertyEnum JOB_SOURCES. get Tag() ) + newLine);
witer.wite ("Targets: " + jobMetaData.get (
Noti fi cati onPropertyEnum JOB_TARGETS. get Tag() ) + newLine);
witer.wite (newLine);
witer.wite ("Job Notes: " + jobMetaDAta.get (
Noti fi cati onPropertyEnum JOB_NOTES. get Tag() ) + newLine );
witer.flush();
witer.close();

}
catch (Throwabl e t)

throw new Runti neException (t);



4. Enter the following code to generate the report. This code also provides a null report if the report type is set to none at execution time.
//Create the report if required
File reportFile = notificationlnfo.getReport() ;
if (reportFile !=null)

File destinationReportFile = new File dir.get AbsolutePath() + File.seperatorChar +
reportFile.getNanme()); eportFile.renaneTo (destinationReportFile);

}
5. Finally, output any DDL or synchronization SQL:
//Wite the script File scriptFile=notificationlnfo.getScript();

if ( scriptFile !'=null) File DestinationScriptFlle = new File (dir.getAbsolutePath() +
File.separatorChar + scriptFile.getNane () );
scriptFile.renameTo (destinationScriptFile);

Implement the Di rect oryNoti fi erContri buti on class

Add the code below to the Di r ect or yNot i fi er Vi ewer Cont ri but i on class to provide functionality for the interface:

1. TheDirectoryNotifierVi ewer Contribution class requires three class-level private attributes. These attributes store notification data,

which is the composite on which any options are placed, as well as the f ol der Fi el d, which is used to enter a file directory address.
private INotifierData notificationDat a;
private Conposite body;
private Text fol derField;

2. The cr eat eFor mCont ent attribute creates a new composite and provides a layout template for options and entry fields. The code below adds a

label and a text field to the interface:

public Conposite createFornContent (Conposite parent, FornTool kit toolkit) body = tool kit.
creat eConposite (parent);

body. set Layout (new GidLayout ());

tool kit.createlLabel (parent, "Target Directory:");

String folder = notificationData == null ? " " " : notificationData.getNotificationProperties().

get (DirectoryNotifierConstants. TARGET_DI RECTORY) ;

folderField = tool kit.createText (parent, folder, SW.SINGE | SW.BORDER);
fol derFiel d. set LayoutData (new GidbData (SWI. FI LL, SWI. CENTER, true, false));
fol der Fi el d. addMvbdi fyLi stener (new ModifyListener () {

public void nodi fyText (MdifyEvent e)

{
notificationData.setNotificationPropert (DirectoryNotifierConstants. TARGET_DI RECTCRY,
folderField.getText().trin() );
}

IOF
return body;
The code does the following:
Creates a new composite body, and sets it to have a grid layout.
Creates a label for the target directory field.
Retrieves the folder from the job, if the job is new or unsaved, or defaults to an empty string if the result is null.
Initializes the f ol der Fi el d text element and sets it to justify.
Adds a listener for changes on the f ol der Fi el d element that updates the not i fi cati onDat a, thus enabling save actions.
® Returns the body to be added to the DB Change Manager job editor to which this class applies.

3. Add the set Dat a method using the following code, which is called to update the user interface with job information. This method accepts and

stores the new instance of | Not i fi er Dat a containing job-specific data for the notifier. If the f ol der Fi el d has already had something
entered, the notification properties are initialized and store the value that was previously entered.
public void setData (I NotifierData notificationData)

this.notificationData = notificationDat a;

if (folderField !'=null && !folderField.isD sposed() & folderField.getText().trim().length() > 0))

if (notificationData !=null) Map<String, String> propMap notificationData.
get Noti ficationProperties();
if (propMap == null)
{
notificationData.setNotificationProperties(new HashMap<String, String>());
propMap = notificationData.getNotificationProperties();

notificationData.setNotificationProperty (DirectoryNotifierConstants. TARGET_DI RECTORY,
fol derFi el d.getText());
}

}

Register the extensions



Once you have coded the plugin and implemented the notifier and user interface, you include definitions that explain how DB Change Manager should
interact with the plugin.

You register the extensions that define the Not i fi er and Noti fi er Vi ewer Cont ri buti on to DB Change Manager. When the plugin is added to DB
Change Manager, the extensions are registered and DB Change Manager understands the purpose of the plugin.

1. Open the MANI FEST. MF file.
2. Navigate to the plugin.xml tab and display the source.
3. Add the following code:
<ext ensi on point="com i dera. change. notifications.notifier">
notifier
id="org.acne.directorynotifier" name="Directory Notifier"
notifier="org.acne.directorynotifier.D rectoryNotifier"
vi ewContri bution="org.acne.directorynotifier.D rectoryNotifierViewerContribution">
</notifier>
</ ext ensi on>
4. Save the file by pressing Ctrl+S or by clicking File > Save.

When or g. acre. di rectorynoti fi er is found, the notification extension point is registered. The noti fi er and vi ewContri buti on attributes are
the class names for two implementations and Eclipse reflectively registers these objects for use in DB Change Manager.

Deploy the Not i fi er plugin

Once the plugin has been defined, you need to deploy the plugin in DB Change Manager.

1. Stop DB Change Manager if it is currently running.
2. Select File > Export.
The Export dialog appears.
3. Choose Deployable Plugins and Fragments from the Plugin Development group.
4. Click Next.
5. Selectorg. acne. di rectorynoti fi er and ensure that the target directory is attributing to the DB Change Manager installation folder.
6. Click Finish.
7. Start DB Change Manager, and then create a new data comparison job.
8. Define a source and target data source, and then navigate to the Notifications tab.

The Directory Notifier appears as a section to the tab.
9. Choose Enable Directory Notifier to enable the feature.
10. Specify the Target Directory, such as C:\ChangeManagerNotifications, and then choose PDF in the Attached Report section.
11. Execute the job, and then open the target folder. A new folder is created containing two output files from the job.
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