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Welcome to DB Change Manager

IDERA DB Change Manager helps database administrators and developers to:

« Simplify and automate database change management.
« Streamline development cycles.
+ Ensure availability, performance, and compliance.

DB Change Manager provides comparison, synchronization, data masking, and auditing capabilities that let you
track and report on changes, roll out new releases, and pinpoint problems resulting from changes at the data,
schema, and database configuration levels.

By comparing a live database to a schema or configuration “snapshot,” administrators can quickly identify changes
and correct problems. By monitoring configuration settings, administrators can ensure compliance with regulatory
policies and performance standards and maintain overall database performance and availability.

What can you do with DB Change Manager?

This topic describes what you can do with DB Change Manager and links to more detailed information about how to
perform the tasks. In addition, DB Change Manager includes step-by- step Eclipse-style cheat sheets to help you
learn the tasks.

« Complete Commonly-performed tasks. These tasks describe basic functions and help you use DB Change
Manager most effectively. In addition, you can customize the interface using preferences. See
the Preferences reference for details.
» Registering and organizing data sources
» Creating a job report
» Scheduling a job
« Filtering data source objects
+ Searching for database objects and synchronization scripts
«+ Viewing Change History
» Exporting and importing jobs
+ Compare and synchronize data. Data Comparison jobs help you manage data changes and synchronize
changes between databases.
« Comparing data
» Synchronizing data repositories
« Compare and synchronize schemas. In DB Change Manager you can select schema objects and types,
compare them across data sources, and synchronize them to each other. You can also create a snapshot or
archive of the schema objects, to use in a comparison or to save for future reference. In addition, you can
clone schema comparison jobs to make it easier to reuse existing jobs.
« Comparing schemas, including how to clone a schema comparison job
+ Synchronizing schemas
+ Creating a schema archive
« Manage database configurations. DB Change Manager helps you keep track of database settings and
version information; such as patch levels. You can define database configuration values and ranges and then
run a configuration comparison job to check for compliance against those parameters.
« Comparing database configuration settings
+ Creating a standard for configuration settings
+ Creating a configuration archive
+ Create masked data for development environments. Protecting personally identifiable information while
having accurate data for testing can be difficult. DB Change Manager lets you create a masked copy of
production data for use during development and testing. This way the data is functionally correct and at the
same time does not compromise privacy or security.
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« Masking data
+ Automate and script jobs. You may need some jobs to run on a regular basis without using Windows Task
Scheduler (as described in Scheduling a job.) The Script Wizard lets you define scripts that run jobs, and
batch files to run multiple scripts.
« Scheduling a job
« Generating command line scripts
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Getting started

DB Change Manager provides features to help you manage databases from development to deployment and
maintenance cycles. These features include:

« Data comparison and synchronization

« Schema comparison and synchronization
+ Database configuration management

» Reports, notifications, and change history
+ Data masking

+ Source control system integration

Data comparison and synchronization

DB Change Manager can analyze and compare the data in two different data sources. It generates a SQL script that
can update one data source so that it matches another. You can modify the SQL and run it as you wish. You can
even define a comparison and synchronization process, called a job, and set it to run automatically. These features
help you better manage common scenarios, such as:

« Keeping primary and backup data in sync

+ Keeping up with data changes during the development and testing cycles, and later on to deployment
environments

« Managing data migrations during upgrade activities

Schema comparison and synchronization

DB Change Manager can capture and compare the database schema in your enterprise. Over the lifecycle of a single
schema, you can capture a baseline or archive schema and analyze changes through time. In addition, DB Change
Manager generates a SQL script that can update a target schema so that it matches a standard. You can modify the
SQL and execute it as needed.

Database configuration management

In addition to schema, there are configuration settings that can vary across an enterprise. DB Change Manager can
capture the configuration settings of a data source. You can capture a baseline or archive configuration and analyze
changes through time. You can create a configuration standard that defines the norms for your enterprise and
against which you can compare your databases.

Reports, notifications, and change history

DB Change Manager supports your data management activities with notifications when processes execute, reports
that capture key information, and change history tracking.

Data masking

There are specific scenarios when you need to hide the true values of the data in a database. For example, during
development you need to protect personal or proprietary data, yet you still need to work with data that accurately
represents the source. By combining data synchronization with data masking features, such as randomization or
shuffling, you can duplicate source data and use the masked copies in non-production or non-secure environments.
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Source control system integration

You can integrate DB Change Manager with source control systems such as Concurrent Versions System (CVS),
Visual Source Safe (VSS), or Eclipse plugins. The Navigator in DB Change Manager is the interface for accessing files
under source control. Job files and archive versions are stored as XML files and synchronization scripts are stored as
text files. You perform all source code control actions using the source control system.
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Product requirements and database support

For the latest list of product requirements and database support, see DB Change Manager Technical Specifications.

Eclipse plugin support
If you choose to install the Eclipse plugin version, you also need the following items:

+ Eclipse 3.6+
« Sun Java Standard Edition 6, Update 45+
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Installing DB Change Manager

To install DB Change Manager on a workstation, run the installer and follow the prompts provided by the
Installation Wizard. When the installation is complete, see the ReadMe file for known issues or advisory notes that
could affect your use of the product.

Installing DB Change Manager in an AppWave environment

If you are a DB Change Manager user and your System Administrator provides you with AppWave, then your System
Administrator enables DB Change Manager in your AppWave Browser. Consult your System Administrator and the
AppWave Browser online help for details.
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Licensing DB Change Manager

DB Change Manager supports the following types of licenses:

« Trial licenses. A license for a time-limited, full-featured trial version of the product. You must register the
trial license before you can use the product.

« Workstation licenses. A license or set of licenses that is tied to a particular workstation. The product can
only be used on that workstation.

« AppWave licenses. AppWave licenses are normally concurrent licenses managed by your System
Administrator. See your System Administrator for details.

Registering a Trial or Workstation license at application startup

Shortly after downloading a trial version of an IDERA product, you should receive an email from IDERA containing a
serial number, which must be registered. These instructions also apply if you have purchased a product and
received a serial number prior to running the application for the first time, or if the trial period expired.

To register a serial number at application startup

1. Start the application. The License Registration dialog appears.

2. Copy the serial number from the email, and then paste it into Serial Number.

3. Enter your Developer Network (EDN) account credentials in the Login, or in the Email and Password fields.
If you have not previously created an EDN account, or have forgotten your password, click I need to
create ... or ’'ve lost my password.

4. Click Register.

The activation file should automatically download and install. If this does not happen, click the Trouble
Connecting? Try Web Registration link and follow the prompts.

Registering a Workstation license after application startup

The following instructions assume that you have received a workstation license by email and that you currently
have a valid trial license. If you did not install a trial version or if the trial period has expired, follow the instructions
in Registering a Tri al or Workstation License at Application Startup instead.

To register a serial number after application startup

1. Click Help > Launch License Manager.

The License Manager dialog appears.

In the License Manager dialog, click Serial > Add.

Copy the serial number from the email, and then paste it into the Add Serial Number dialog.

Click OK.

Expand Unregistered Serial Numbers, right-click the serial number just added, and then click Register.
A registration dialog appears.

AR S

@ The Registration Code box shows a machine-specific identifier required with other registration
methods.

6. Ensure that Register using Online Registration is selected.

Provide Developer Network credentials in the Login field, or into the Email and Password fields.

8. Click Register.
The activation file should download and install automatically. If this does not happen, click the Trouble
Connecting? Try Web Registration link and follow the prompts.

~
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Registering by phone

If you have problems with either of the above procedures, you can register licenses by phone. You must provide the
following information:

Developer Network credentials;

registration code displayed in the License Registration dialog that appears when you start an unlicensed
application;

product base license serial number; and

license serial numbers for any additional features purchased

For North America, Latin America, and Asia Pacific: call (415) 834-3131 option 2, and then follow the prompts.
The hours are Monday to Friday, 6:00 A.M. to 6:00 P.M. Pacific time.

For Europe, Africa, and the Middle East: Call +44 (0)1628-684 494. The hours are Monday to Friday, 9 A.M. to 5:30
P.M. U.K. time.

After phoning in, you will receive an email containing an activation file to import into DB Change Manager.

To import an activation file

1.

ok wnN

Save the activation file from the email to the desktop or to a scratch directory such as c:\temp.
From within the application, click Help > IDERA Licensing > License Registration.

Click License > Import.

Navigate to the directory where you saved the activation file and then double-click the activation
Click the Import button to import the activation

Click Finish.
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Key concepts of DB Change Manager

« Understanding jobs and scripts in DB Change Manager
» Understanding the DB Change Manager User Interface

Understanding jobs and scripts in DB Change Manager

DB Change Manager uses the concept of a job to organize reusable processes. A job uses objects of the following
types:

- Data source. A data source is a data repository or database.

« Configuration standard. A standard is a customized set of properties with threshold operators that help
you create optimal configurations against which you can compare other data source configurations.

+ Schema or configuration archive. An archive is a snapshot of a configuration or schema.

You can use this archive to compare against other schemas or configurations.
There are two types of jobs in DB Change Manager:

+ Object creation jobs. Some jobs create objects that are used in other jobs. You use a job to create
configuration standards and archives.

« Comparison jobs. Processes source and target objects and provides information describing their similarities
and differences. This comparison is then used to generate SQL scripts. A comparison job can be of the
following types:

- Data comparison. Looks at the data repositories of two data sources and determines their
differences. You can use this information to determine whether to update a target data source.

« Data masking. A special kind of data comparison job that creates a copy of sensitive data, which
masks the true values of specified fields.

+ Configuration comparison. Determines whether the configuration settings between a source and a
target are the same. This information helps you quickly diagnose problems.

« Schema comparison. Lets you compare the schemas of different data sources or archives. It helps
you manage schema changes through development, testing, and production cycles.

Once it has run a comparison job, DB Change Manager can generate an SQL synchronization script that can update
target data, configurations, or schemas. You can modify a script before you run it. For example, you can use a DB
Change Manager script to synchronize data between development and testing environments. Once you are
comfortable with the job’s specifications, you can let it automatically run the script and synchronize the data.

You can group jobs and scripts into projects, which are visible in the Project explorer and in the Navigator view. The
Navigator view provides a way to interact with files in a source control system.

Understanding the DB Change Manager User Interface

The Workbench is the DB Change Manager development environment. It provides you with an interface to create,
manage, and navigate comparison jobs through interaction with views, editors, and menus. If you are familiar with
Eclipse you will recognize many elements of the interface.
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The Welcome Page is the first screen you see when you initially launch the application.
information that may be of value to new users.

The screen provides links to

Views help you navigate a hierarchy of information, open editors, or display the properties of various application
elements. For example, the Data Source Explorer view provides a tree of all data sources in the environment and the

comparison jobs associated with each. You can launch these jobs directly, modify the ¢
sources, or create and edit configuration archives from the view.

onnection properties of data

Editors help you perform various tasks, such as running a job. For example, you use the Schema Comparison Job

editor to define and execute schema comparison jobs.

The Menu Bar and Command Toolbar options provide various functions, such as launching views and editors,

navigating, and setting preferences.
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Tutorials for DB Change Manager

° Before working with tutorials, identify two data sources that you can use for practice. These data sources
should not be live or mission-critical, and they should be similar in schema and data.

This section guides you through the key features of DB Change Manager using the following step-by-step tutorials:

+ Tutorial 1: Comparing data

+ Tutorial 2: Synchronizing data

+ Tutorial 3: Comparing configurations

+ Tutorial 4: Defining a configuration standard

+ Tutorial 5: Comparing and synchronizing schemas
+ Tutorial 6: Defining a schema archive

+ Tutorial 7: Masking data

« Tutorial 8: Defining and running automated scripts
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Tutorial 1: Comparing data

0 Before working with tutorials, identify two data sources that you can use for practice. These data sources
should not be live or mission-critical, and they should be similar in schema and data.

Data comparison jobs automate the process of comparing and correcting data between data sources at the
database, table, and row level. You select a source and a target data source from Data Source Explorer, map
databases and tables between the two selections, and then run the comparison job.

DB Change Manager compares the information and returns a results screen with details including:

« An overall percentage of the data that is the same between the source and target
« Discrepancies between the two databases, such as data values that exist on only one

Once a data comparison job has run, you can then correct any synchronization issues by running an automatically-
generated SQL script that adds missing rows and updates out-of-sync values. You can modify the SQL script prior to
running it, and store it for future use.

To start Change Manager
« Start Change Manager using the Start menu’s IDERA DB Change Manager [version] item.

When DB Change Manager first starts, it displays a Welcome screen. Review the Welcome screen options, and then
closeit.

Adding data sources

In order to define and run jobs, you first register data sources by providing connection information and other details
to DB Change Manager. Once a data source has been registered, it remains stored in a catalog and does not need to
be reregistered each time you open DB Change Manager. You can use a single registered data source in multiple
jobs.

Data Source Explorer shows the registered data sources and their associated jobs, if any. Before registering a data
source, gather the information about the repository location and connectivity permissions.

To add a data source

1. Click the Discover Data Sources icon at the top of the Data Source Explorer view.
File Edit Search Run Tools ‘Window Help

L=~'1J.- - JE‘:j Q - ‘% -
95 Data Source Expl £2 - % 1ob Explorer | ©5 Mavigator | O
=
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2. Inthe Discover Data Sources wizard, select the locations to search for data sources, and then click Next.

"% Discover Data Sources

Discover Data Sources
Sielect the locations to search for data sources.

CPreviously regitered Embarcadero data sources (Registry)
CIFik: systern and retwork
[ClEclipsa Data Took Platform (OTF)

CQuest Software (TOAD)

3. Select the data sources you want to add to the DB Change Manager environment, and then click Finish.
3 Data Source Bxpl, £, ¥ J0b Explorer | . Navigator | — O

-l B89 7

| v [
EL
= 1= Managed Data Sources (&)
# = Microsoft SQL Server (3)
# 1= MyGroup
= 1= SFTest (1)
= 1= Microsoft SOL Server (1)
ERs |SPALARDOZ/TEST (SCOL !
& [ TORLABINTERBOL (InterBase 9.0.0.206)
& Ml TORLABINTERBOZ (InterBase 9,0.0,206)

The new data source or sources appear in the Data Source Explorer.

© Analternative to using the Discover Data Sources wizard is to click File > New Data Source and set
its connection properties.
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4. Inthe Data Source Explorer, right-click on a data source and select Properties to work with connection

properties for the datasource.

Data source name: | SPWLABDORZ/TEST

Microsoft SOL Server
®se a network lbrary configuration

Server allas: | SPWLABDOZATEST

Oise a direct connection

Default databasa:

Security credentials
User name:’|
Password:

[CJauto-connect (Sawes and encrypts password)
[ allow trusted connectiors

Creating a data comparison job

Prior to performing the following steps, make sure you have at least two data sources registered in DB Change
Manager. Ideally these two data sources are similar in schema and content, so that the comparison is meaningful to

you.
To create a data comparison job in the Overview tab

1. Click File > New > Data Comparison Job.
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IDERA DB Change Manager 18.9

2. Usethe Select a Project dialog’s Create New button to open a dialog that lets you provide a name and
location for a project for this exercise. Select the new project from the Select a Project dialog.

Tog o g n gl n

& Owerview | = Options | [ Mapping | [ Notification | = History t:’ =) &)
3 Step 1: Select a source and target to compare and name the joby next =

it Create or Modify a Data Comparison Job

Job Name and Description
HName

Urititled-Data-Cormpar ison- Job-1

Froject: Change Management

[ Track results in Compliance Explorer

Job Sources

& Data Comparison Source & Data Comparison Target

Marme: Marme:
Type: Type:
Hast: Hast:

i Select Datasource & Select Datasource

Owerview | Options | Mapping | Maotification | History

3. Inthe Overview tab, type the name of the job in the Name field.
4. Click and drag a data source from Data Source Explorer to the Data Comparison Source box.

By default, all databases in the data source are selected. If you prefer, use the menu to specify a single
database.

5. Click and drag a data source from Data Source Explorer to the Data Comparison Target.
6. Click File > Save or type Ctrl+S to save the job.

To customize the job in the Options tab
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1. Click the Options tab.

> Overview | Options bunﬂm!bum-ﬂm B History 6 E’ @
¥ Step & Customize the comparison and mapping (pairing) of tables and columns << ack next =>

= Execution Options
[l autnmatically Synchronize

Clear all data on the target and replace it with all data from the source automatically. If unchecked,
' oLl Can Feview the comparison results and select rows
- ripls. This will disable tracking results in Compliance
anged i s significant way you will resd o renepect e pakr,

O Compression Corrparison
With thiz option enabled data on your datasolrces B compressed before being ransmitted 1o the
workbench and compared. In certain situations data compression enables the job to run at & rmuch
faster rate by removing the need to transfer and compare large volurmes of data

O Generate CML
Automatically output the synchronizabion DL resulting from job execution, This DVL file can then
cation

ly be sent with any enabiled Notifi

= Mapping Options

[lignore Case B fsell
) J @] |

Crverview | Options | Mapping | Motification History |
2. Inthe Options tab, review the various settings available to you. In particular, select or de- select the check
boxes in the Mapping Options section.

+ Mapping Options
[Flignore Caze

Databases, owners, tables and columns will be paired up for comparison without regards to case. For
example, with this option salscted the table "Product_Prices" will be paired with table
"PRODUCT _PRICES"

[Flignore Spaces
Pairs database objects for cormparson ignoring spaces in thelr names. For example, with this cption
sabectad the table "Froduct Prices” will be pained with the table "ProductPrices”.

[lrgnore Underscores
Pairs database objects for comparson ignoring underscores in ter names. For example, with this
option selected the table "Product Prices" will be pared with the table "ProductPrices"

Oinchude views
Enable this option to nclude views in the mapping. Ctherwize, views will be filtered out of the mapping
and will not be compared. hote that with this opticn enabled, you may still sslect which views (i any)
'ish o inchude i the cormparson,

YO

[ Enchude Computed Cokimie

Enable this option to exclude from mapping (and cormparson) the colurmns whose values are computed,

To refine comparisons in the Mapping tab
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IDERA DB Change Manager 18.9

+ Click the Mapping tab.
+ Select the databases you want to compare; usually they have the same or a similar name.

W lalyy i g
B Owerview | = Options | [ Mapping | B lotification | = History t‘y - B
¥ Step X Pair databases, schemas, owners, tables, and columns between the source and target =< hack next x>

+ Database Mapping

TORLABSOLOO_3 TORLABSCLOO_1
master master Source: pubs
rrcche| rrode| Target: pubs
rrsch rnscl
- P— P— Inspected: [Mot Inspected]
b pubs pubs Inspect: All | Current | Checked
] SakesCd [Urimapped)
tempch tempdb * Refresh Databases
Feydaa [Unmapped] * Remap to Defaults
" =

Select: All , None

* Tabile Mapping
The selected pair has not yet been irspected, Would you like o inspect the table and column pairs in these objects?

.‘._1./ E i

[ v

<

1 A - e

Overview Options Mapping Notification History

© Use the Alland None commands at the bottom of the pane to select all or none of the databases.

« By default, DB Change Manager does not show the table mappings. To see them, select the Inspect:
Checked option on the right side of the Database Mapping pane. The progress bar displays in the lower
right corner. The Table Mapping pane shows how and whether the tables map to each other in the two

databases.
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IDERA DB Change Manager 18.9

=Tm

[ Overview | [ Options | [ Mapping | > Hotification | > History | Qy =) &
L& mtrﬁm-%mnﬁmnm-.aﬁm- hltlrmﬂn source and target =< back pest >>
T LT W ST " - I ,';]
% 40 pubs pubs Irspect: All | Current | Checked -
[] Salesls [Unimapped]
= tempdh tempd k Refresh Databases
$5594a [Unmapped] » Bemap to Defalts
i . _ @l
Select: All , Hone
= Table Mapping
N TORLABSQLOO_3.pubs TORLABSQLOO_Lf 4
M oo APPTEST [Unmapped] Source:
i B @ dooauthors [ dbo.authors Target:
O O dbo.azsy [Urimapped]
I doo.azss_hzecff7 [Uriirapped] Columns:
O [ dbo.blob [Unmapped)
0 dbo.ca [Urimapped)
El-E I dbo.cCa [Unmapped)] Flker:
O @il O dodscounts [ dbo.discounts ’
= @8 @ dooemployes [ dboemployes .er
cA nm | [N A e i s
] | 2
Creerview | Options | Mapping | Motification | History

The Data Comparison Job Editor automatically maps and selects databases and tables between the source
and target when it detects correspondences. It indicates when there is no mapping and displays information
when it cannot make a match.

+ Table Mapping
TORLABSCLOO_3.pubs TORLABSQLOD_15 4 _

O 0 dooca [Unmapped] Source: dbo.publishers
1. dho.Ca [Urirnzpped ] | Target: dbo.publishers
O @ia [0 doodsoounts [ dbodiscounts | . o
& . B8 [ doo.employes I dboemplyes Columns: 5/5 o 5/5
¥ . B8 @ dojobs M dbo.jobs .
1L, 0 dho.newtablel [Unmapped] i b gy
F. B0 D@ deopib_info [ dbopub_info Flter:
¥ 5l oo, publeshers [ dbo.publishers Sl et
[0 @AThe following ermars have been found:
0 Table or Wiew can not be ool if there is no column selected as iscn
g} M doosimpleTestTablels_eSd4fic?  [Unmapped]
b B8 @ dbo.stores [ dbo.stores
1. I dbo.students_aCK1 [Unrnapped] -
- L B P S ' L latan b Ll —in ] R rr————y | Lo}

%] | [

Select: all | None

+ Select or de-select the check box next to each mapping, as needed. You can adjust incomplete mappings
before running the job. Click undefined items in the Target data source column and use the drop down
menu to map them.
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IDERA DB Change Manager 18.9

o Click Filter: edit while a pair is selected to use the Columns, Comparison Key, and Filter dialog and further
refine the mappings, such as inserting a WHERE clause.
To specify notifiers in the Notification tab
1. Click the Notification tab.

Lintitec-ata- o mpar =0

B Overview | B Options | [ Mapping | [= lietification | B History w = &

¥ Step & Turn on and customize notifications for wien the job runs << back FINISH

~ Email Notifier

ClEnable Email Matifiar
Enable this Notifier to see its settings hiere.

= Fila System Notifier

[CEnsble File Systern otifier
Ensble this Notifier to see its sattings here.

= System Tray Notifier

[Clensble System Tray Motifier
Enablke this Notifier to see its settings here,

Cwerview | Options | Mapping | Motification | History
2. Inthe Notification tab, select where DB Change Manager sends notifications when this job is run.

To run the job and see the results

1. Click the Run Job icon located in the upper-right side of the window.

) =)

The Results tab displays the job progress bar and the results, when available.
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IDERA DB Change Manager 18.9

2. Click View in the Results column to view information for an individual pair.

s

(%) "Date Corpere - Tolebsahio 2 71 -

B> overview | B> Optione | B> Mapging | B> Hotifieation

F-Hlﬂnryib Results bmmﬂemmu; @ 1o ) -!

Cose results

+ Resulbs Overview - activation

a Source! actv... |Target activation |Matched | only in tarlsbegl,.. |only in TORLAB... |Differant o2, Source 14
tho.achwation_key cho.achwaton_key 0 1] a a a
dbouactivation k.. dbo.acivation k.. 0 a a a a
tho.achwatian_k... cho.achkwafton k... 0 ] Q a a
dbo.activation_... dbo.acivation ... D a a 1] 1]
cho.copadty cho.copadty = 18 a a i i >
<_ L l
|Z}, view DiffReport  [2] Ewport Diff Resuits. ..
= Sclected Table

1] o

Y]

=

]

=

(1]

Select Al

showrows: (53 al imematched O Source ) Onlysource ) Target (3 Orly target

Ganerats a S3L Sopt

Overview | Cptiors | Maoping |Motfication | History | Results | Datebese Results |
= — ——

3. Inthe Database Results tab, review the detailed results for the tables and rows of the selected databases.
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Tutorial 2: Synchronizing data

0 Before working with tutorials, identify two data sources that you can use for practice. These data sources
should not be live or mission-critical, and they should be similar in schema and data.

To generate and run an SQL synchronization script

1. Atthe bottom of the Database Results tab of a database comparison job, click one of the radio buttons, such
as Mismatched, to specify the type of resolution to perform.
2. Atthe lower right, click Generate an SQL Script.

= Syrc dorlaisglD0_2 Apr 27, 2008 4 55_20 Mgl i3 |
¥ o} Mioosoft SOL S=rver b Sy torlebsglio_2 (3.0.2039.0) k[ perf_anca [~ T

ws romlabartorcifi )

SOURCE DATA S50URCE ¢ o

CEEATE TASBLE ddd.TESTINDULTIMA
|

gdfgfd numeric HUOLL,

gdfgd numeric HULL

1
[=]=]

=IF CGBJECT_ID(N'ddd.T
PRINT H'<<< CRE
ELSE

PRINT N'<£<«< FATLED CPELTING TAELE ddd.TESTIIMOULTIMA »>2>"

A"} IS5 HOI HULL

go

3. Inthe SQL Editor, click the Execute SQL icon, the green arrow, to synchronize the data.

o Executing an SQL script may change the data in your data sources. Be sure to review all potential
changes, and read the script, before running the script.

4. If you want to create a report, select the Database Results tab, and then click View Diff Report.

Highlighted Feature: The Compression Comparison Option

Comparing large repositories with many databases, tables, and rows can be a time consuming and tedious process,
especially when you require row-level accuracy.
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The Compression Comparison option enables an algorithm that causes the data comparison to initially execute at a
table level instead of the row level. Each table in a pair is assigned a value and if the values match the comparison
process moves to the next pair of tables. If the values do not match, the process performs a more detailed
comparison at the row level. This allows for a faster comparison process in general, without losing any accuracy
during the process.

[JCampression Comparison

To enable this feature, navigate to the Options tab > Execution Options section, and then select Compression
Comparison.
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Tutorial 3: Comparing configurations

° Before working with tutorials, identify two data sources that you can use for practice. These data sources
should not be live or mission-critical, and they should be similar in schema and data.

Configuration comparison jobs examine the configuration settings of two specified data sources and describe the
differences between them. You select a pair of data sources from Data Source Explorer, refine the property
comparisons, run the job, and view the results. Based on the results you can correct any issues between the pair.

You can also compare a data source against a configuration archive or standard. Archives are a snapshot of the
configuration settings of a data source at a point in time. Standards are customized sets of properties with
threshold operators that help you create optimal configurations; against which you can compare existing data
source settings.

To define and run a configuration comparison job

1. Select File > New > Configuration Comparison Job. If prompted to select a project, select the project you
created earlier.

2. Type the name of the job in the Name field.
3. Dragand drop a data source from Data Source Explorer to the Configuration Comparison Source box.
4. Dragand drop a data source from Data Source Explorer to the Configuration Comparison Target box.
5. Click the Refinements tab.
6 *Untitled-Data-Cormparisor-Job-1 | 2k *TestingConfigComparel
B Owerview | [ Refinements | > Options | B Notification | [ History 'E\:j' - r_]|
¥ Step 1 Select the configuration pooperties to compare << hack et >>

Configuration Property Refinement
::'Iease select from the properties below those that you would ke to dhedk in your configuration comparison job.

Property Type Description
# [#] B SOL Server Yersion Information
# [#] B Core SCL Properties

<. ¥

Owerview | Refinements  Options | Notification | History

6. Keep the defaults in the Refinements tab.
7. Click the Options tab.
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8. Inthe Options tab, select the Extract DDL check box.

B Overview | Refinements | [ Optlons | B Notlfication | b= History @ = &
¥ Step 3 Customize the job with the settings listed below o hach peed o>
Make thess the defaults for new jobs Restore defaults

= DOL Extract Options

Extract DOL

9. Click the Run Job icon.
10. Inthe Comparison Results tab, the job progress bar displays and the results appear. Review the job results.

i *Untited-Data-Comparison-Job-1 b *TestingConfigCormparel [ =0

B Owerview | B Refinements | [ Options | B Notification | [ History | [ Comparison Results w =) &)
Close resylts
Comparison Summary Resalution
Generate a SOL SCript

Scurce: e TORLABSOLOS 1 Target: m TORLABSQLOO 3

¥ 53 Properties Malched 52.9% I
K 12 Properties Did Mot Match 13.3% N
¥ 25 Properties Not Found 27.8%

Comparison Resilts
Property = Source Op TORLABSOLOD_32 Ll
| R e e (1] = m A ¥ N i

Owerview | Refinements | Options |MNotification History Conparison Results

In the Comparison Results tab, you can generate an SQL script to synchronize the configurations just as in
Tutorial 2: Synchronizing data.

Highlighted feature: Comparing multiple targets

You can compare multiple target sources against a single source. In the Configuration Comparison Target box of the
Overview tab, click the Add More Targets option. The box changes to a column list view, where you can drag and
drop additional sources from Data Source Explorer to the Configuration Comparison Target box.
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Tutorial 4: Defining a configuration standard

° Before working with tutorials, identify two data sources that you can use for practice. These data sources
should not be live or mission-critical, and they should be similar in schema and data.

A configuration standard is composed of properties and values that you define:

« Configuration properties (static or dynamically updated based on the source values)
« Values thatinclude threshold comparison operators (greater than, less than, falls within or is a member of a
specified set, etc.)

You can use a standard in configuration comparison jobs against data sources and archives in order to determine if
the target conforms to the standard. A standard can only be used as a source in comparison jobs.

To define a configuration standard

Select File > New > Configuration Standard.

If prompted, select a project to use.

In the Overview tab, enter the name of the standard in the Name field.

Drag and drop a data source from Data Source Explorer to the Standard Sources table.
i) *Uritithed-Data-Cormpar ison-1ob-1 b * TestingConfgCamparel [ *configStandardl

i N S

= Onverview :r" BEetinement
[ Create or Modify a Configuration Standard

Standard Name and Description
MNarme MNates
ConfigStandardi

Propct: ConfigCompare 1

Standard Sources

ersion

Sourca
| | ToRLARSOLOO 3 Microsoft SOL Server ...

Hostname: TORLARSOLOD_3
Typa: Linked

[+ 3
Owerview | Refinement

5. Inthe Refinement tab, define each listed property using the Source, Operator, and Value controls.
6. Select File > Save to save the standard. It appears in the Project Explorer.

You can subsequently drag and drop the new standard from Project Explorer to the Comparison Source box in the
Configuration Comparison Job Editor. You can then run a job using the standard as you would use a registered data
source.
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Tutorial 5: Comparing and synchronizing schemas

(X

Before working with tutorials, identify two data sources that you can use for practice. These data sources

should not be live or mission-critical, and they should be similar in schema and data.

Once you create a baseline archive of your schema, you can compare it against the other schemas, even in live
environments. Also, you can synchronize the schema of a data source with the archive using the Schema
Comparison Job editor.

To define a schema comparison job

ok whr

Select File > New > Schema Comparison Job and if prompted, select a project.

In the Schema Comparison Job editor, type the name of the job in the Name field.

Drag and drop a data source from Data Source Explorer to the Schema Comparison Source box.

Drag and drop a data source from Data Source Explorer to the Schema Comparison Target box.

Click the Mapping tab.

In the Mapping tab, review the object mappings that are already set up for you. Change the target mappings
as needed.

In the Options tab, select or de-select the configuration properties.

Click the Run Job icon.

In the Comparison Results tab, the job progress bar displays and the results appear. Review the job results.

To generate and run a schema synchronization script

1.

N

In the Comparison Results tab, click Generate Sync Script in the Resolution column of the Comparison
Results table. DB Change Manager generates a synchronization script in the SQL Editor.

Modify the script as needed, and save it using the File > Save command.

In the SQL Editor, select the Execute SQL icon to synchronize the data.

0 Executing the SQL script changes the schema in your target data source. Be sure to review all
potential changes and read the script before running it.

If you want to create a report, click Generate Report. The Export dialog opens and provides additional
report options.
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Tutorial 6: Defining a schema archive

0 Before working with tutorials, identify two data sources that you can use for practice. These data sources
should not be live or mission-critical, and they should be similar in schema and data.

A schema archive contains a snapshot of the schema of a registered data source. You compare schema archives
against other data sources and archives to identify possible inconsistencies.

A schema archive is generated from a single data source at a specific point in time. Like a configuration archive, a
schema archive has versioning functionality and can be periodically updated with the current values of the data
source. Older versions are retained and can be recalled as needed.

You create a schema archive using the Schema Archive Job editor. Once created and saved, it is listed in the Data
Source Explorer.

To define a schema archive

1. Right-click on a data source in Data Source Explorer and select Archive > Schema Archive Job. Select a
project, if prompted.

2. Inthe Archive Job editor, enter the name of the archive in the Name field.

3. Inthe Refinements tab, narrow the job down by selecting owners, object types, and specific objects to
include.

4. Clickthe RunJobicon.

5. Inthe New Unsaved Version tab, the results appear. Review the job results.

6. Click File > Save. The Unsaved Version tab changes to Version 1, and Version 1 appears in the Datasource
Explorer tab under the datasource you chose.

o You can create more versions by clicking the Run Job icon again.
You can subsequently drag and drop the new archive version from Data Source Explorer to the Source or Target

boxes in the Schema Comparison Job editor. You can now run a job using the archive just as you would use a data
source.
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Tutorial 7: Masking data

0 Before working with tutorials, identify two data sources that you can use for practice. These data sources
should not be live or mission-critical, and they should be similar in schema and data.

Data masking is a way of securing sensitive data during the development or testing phases of a database
development project. It is often performed as a security or compliance measure that protects important
information. By masking valid production data, you can provide a copy of the data that is “scrambled” but still
represents your production environment.

To mask data

1. Select File > New > Data Comparison Job and if prompted, select a project.

2. Provide a name of the job in the Name field and then drag and drop datasources from the Data Source
Explorer to the Data Comparison Source and Data Comparison Target boxes.

3. Inthe Options tab, ensure that Automatically Synchronize is selected and read the description shown for
that option.

4. Inthe Mapping tab, select a row corresponding to a matching database pair in the Database Mapping box,
and then select Yes retrieve the objects in this pair.

= Table Mapping

TORLABSOLOS 1 Frankhma TORLABSOLOS 2.F
v if] I doo.Address [0 dbo.Address | Source: dbo.Address
e i T doo.Category [ dooCategory | arget: dbo.Address
¥ 1] O doo.Customer [ dbo.Customer
v k] T dbo.Customer_tddress [ dbo.Customer ¢ Columns: 7/7 o 77
o il O doo.Customer_Order I dbo.Customer _( :
» 1] I doa.Customer_Order_Product I dbe.Customer_t Yigw Cobmn Mapoing
¥ ia 1 dbo.Product [ dbo Froduct Default Masking Rule:
= il O dbo.Ref _sddress_Type I dboRef_sddes T —
Z .. B8 I cbo.Supplier M doo.Supplier e |
&poly to All
Columns: No Masking
Filter: edit
Fa| 3/ [no filer]

Select: All , None
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5. Inthe Table Mapping box, click View Column Mapping.

Columns and Filter &3
| |Tﬁ.fl:le |C|:|Iumn |Ma5l=:ir‘u:| Rule |C|:|Iumr‘| |Tﬁ.fr:le

il it Address ID [(ugl= | Address 1D ¥ int

il it Address Type ID Mone  Address Type... v int

] varchar  Street 1 andormize AR == ) “ varchar
b varchar  Street 2 Use Default v Street 2 w | yarchar
il varchar  City se Default v City  wvarchar
o char State se Default v State | char

[ char Zin Use Default v Zip w char
Select: All , MNone

Columns | Filter

6. Click on the Data Masking Rule option for a column and select one of the following:
+ Use Default. The default masking rule as set in the Database Mapping box.
+ None. No masking is applied.
« Randomize. Replaces characters with other random characters.
« Shuffle. Reorders the values in different rows; for example, in a First Name column, Bob, Ted, and
Alice can change to Alice, Bob, and Ted.
7. Close the window.
Continue to experiment with selection and settings until you are comfortable with masking options.
9. Click File > Save to save the job.

®
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10. Click the Run Jobicon.

R e - # intitleckData-Compar on-Job-1 X =lm
B> Overview | > Options | > Mapping | > Notification  j> History | j» Results || Database Resuits B - &
-~
Close results
 Results Overview - Franklyna
Source: Fran... |~ Taroet: Fra... |[Matrhed |Only in TORL... |Orily in TORL... |Different inl
dbo.Category cdbo.Cateoory I 16 ] a ] g =
dbo.Customer  dbo.Customer O 1] X 348 0 [y
<] - ] )
[ view Diff Report [0 Export Diff Results.,,
= Selected Table
I TORLABSQLOS_L Franklyna, dbo.Custormer TORLABSQLOS_2 Frarklyna.dbo.Customer
.. [Customer 10 [First Mame  [Last Nara| = | [Customer 1D [First Name  [Last mﬂ
734 lames Battiste — 734 Gk LA
75 Sarmual Philpott - 735 Jacigb Fvwizfiac
736 Moa| Arra o 736 ol Eaae
737 Gaston m{f;j 737 Oheybx W
[ —— B o |[Elhs ]
; v
Owerview | Options | Mapping | Notification | History |Results | Database Results |
The Database Results tab shows the masked data.
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Tutorial 8: Defining and running automated scripts

0 Before working with tutorials, identify two data sources that you can use for practice. These data sources
should not be live or mission-critical, and they should be similar in schema and data.

When you need to repeatedly run the same job, you can set up automated tasks that execute the jobs on a regular
schedule. DB Change Manager helps create a command line executable for any job. You can run the command line
executable on an ad hoc basis. You can also group the commands into a batch file and run them.

To define command line syntax and generate batch files

Open the job for which you want to define an execution script.

Select the Command Line Syntax icon in the upper right of any tab.

In the Script Generation Wizard, add output report options.

Specify the Directory where the files are generated.

Click Next.

Specify the Location where the batch file is generated.

Specify the file format for the script.

Click Finish.

DB Change Manager generates the file and saves it to the location you specified.

Nk~ WM

If you want to add multiple jobs to the batch file, generate a batch file as normal, and then copy the script syntax to
the clipboard for each job you want to add to the batch file. You can then add them to the existing batch file
manually.
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