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This help provides the following topics for Precise Interpoint for Siebel:

Performing post-installation action items on a Siebel instance
Uninstall action items
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Performing post-installation action items on a Siebel instance
This section includes the following topics:

About performing actions on a Siebel instance
Setting up Siebel batch process sampling
About sampling Siebel batch processes (SQL Server)
Modifying the Siebel Repository File (SQL Server)
About sampling Siebel batch processes (Oracle)
Modifying the Siebel Repository File (Oracle)

About performing actions on a Siebel instance
The Interpoint for Siebel extension of Precise for SQL Server and Precise for Oracle can only receive notifications of 
user events if specific objects are included in the Siebel Repository File (SRF). Before you can use Interpoint for 
Siebel, you need to modify the SRF file.

Setting up Siebel batch process sampling
For Siebel batch processes to be sampled by the Siebel AppTier Collectors, you need to create a tab-delimited text 
file that contains the mapping of each Siebel server to its host machine and network address. Each row in the file 
represents a physical machine. The first field in each row should represent the name of the Siebel server, the 
second field its corresponding host machine name, and the third its network address.

About sampling Siebel batch processes (SQL Server)
If you have installed Interpoint for a SQL Server database, perform the following procedures.

To create the text file

Log on to the database server where your Siebel AppTier Collector is installed.
Create the following tab-delimited text file:
<Precise_root>\products\sql-server\<instance_ name>\etc\siebel_machines.txt

To obtain the list of Siebel servers

Log on to the SrvrMgr utility.
Execute the following command:
list servers 
Each returned row represents a Siebel server.

To obtain the host machine name and network address

Copy the getAddress.vbs script from the Utilities\Siebel directory on the installation DVD to the server.
Run the following command:
cscript //nologo getAddress.vbs ODBC data source
Administrator user name Administrator passwords 
where ODBC data source is the name of the ODBC data source used by the Siebel server to connect to SQL 
Server. To determine its name, check the ConnectString value in the siebel.cfg configuration file.
Administrator user name and Administrator password are the user name and password required to connect 
to the SQL Server instance.
Repeat these steps for each Siebel server.

Following is an example for the content of the siebel_machines.txt file:
sieb1 APPSRV1 00096B26E66C
sieb2 APPSRV2 00096B26E67C
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Modifying the Siebel Repository File (SQL Server)
Once the Siebel AppTier Collectors are installed, modify the Siebel Repository File (SRF), so that Interpoint for 
Siebel will be able to receive notifications of Siebel-related user events.

Part of the .srf file, is a collection of callback scripts, which are triggered by various events in a user's session. A user 
can view or change these scripts using the Siebel Tools.

For each targeted Siebel application, modify the .srf file on the Siebel server. Define the application name by 
hard coding it in the Application_PreNavigate function.
The modified SRFs need to be distributed to each of the Siebel servers

If you have installed Interpoint for Siebel for a SQL Server database, modifying the SRF consists of the following 
tasks:

Creating the Precise Interpoint project (SQL Server)
Creating the CX_VTSSPID table (SQL Server)
Creating the business component (SQL Server)
Creating the business object (SQL Server)
Adding the Application_PreNavigate() function (SQL Server)
Replacing the table with a custom view (SQL Server)
Completing the modification (SQL Server)
Debugging the script (SQL Server)

Creating the Precise Interpoint project (SQL Server)
The following procedure creates the VERITAS Interpoint project. All objects created in the procedures following on 
this procedure will be grouped under this project.

To create the Interpoint project

Open Siebel Tools.
In the Object Explorer, on the Types tab, select Project.
Create a new project by pressing Ctrl+n.
Name the new project, "Precise Interpoint."
Lock the project by clicking the Locked column to the right.

Creating the CX_VTSSPID table (SQL Server)
The following procedure creates a table in the DBMS.

To create the CX_VTSSPID table

From the File menu, select New Object.
In the New Object Wizard, on the General tab, select Table; then click OK.
In the General dialog box, do the following:

In the Enter a name for the new Table text box, type CX_VTSSPID.
From the Choose a Project in which you wish to create the Table list, select Precise Interpoint.
Under Select the type of the Table, select A stand-alone Table.

Click Next; then click Finish to close the dialog box.
In the Tables workspace, click Apply.
In the Apply Schema dialog box, if needed, type a valid privileged user ID and privileged user password into 
the relevant text boxes.
Click Apply. The dialog box closes, and the table is created.
In the Tables panel, click Activate to activate the new table.
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Creating the business component (SQL Server)
The following procedure creates the VTS_SPID business component.

To create the business component

In Siebel Tools, from the File menu, select New Object. The New Object Wizard opens.
On the General tab, select BusComp.
Click OK.
In the New Business Component dialog box, do the following:

In the Enter a name for the new Business Component text box, type VTS_SPID.
From the Select the Project this Business Component will be part of list, select Precise Interpoint.
From the Select the Table this Business Component will operate on list, select CX_VTSSPID.

Click Next.
In the Single Value Fields dialog box, from the Select a column in the Base table list, select ROW_ID. A 
default Field name automatically appears in the Enter a name for the Field text box.
Click Add to move the selected row to the table; then click Finish to create the business component.

Creating the business object (SQL Server)
The following procedure creates the VTS_SPID business object.

To create the business object

In Siebel Tools, in the Objects Explorer, on the Types tab, select Business Object.
In the Business Objects panel, from the Edit menu, select New Record. A new record is added to the table in 
the Business Objects panel.
In the Name column, type: VTS_SPID.
In the Project column, assign the new record to the VERITAS Interpoint project.
On the Types tab in the Object Explorer, select Business Object > Business Object Component.
From the Edit menu, select New Record. A new record is added to the table in the Business Object 
Components panel.
In the BusComp column, type: VTS_SPID.
From the Tools menu, select Compile Project.

Adding the Application_PreNavigate() function (SQL Server)
The following procedure adds the Application_PreNavigate() function.

To add the Application_PreNavigate() function

In Siebel Tools, from the View menu, select Options.
In the Development Tools Options dialog box, on the Scripting tab, note the value of the Scripting Language 
list and click OK.
In the Object Explorer, on the Types tab, expand Application.
Right-click on the application to be modified and select Lock Object.
Right-click on the application to be modified and select Edit Server Scripts.
In the Server Script Editor, select the Application_PreNavigate function. The function's default script 
appears in the text panel.
If this function already contains a custom script, contact Precise Customer Support for alternative 
instructions.
Replace the default script with the following script:
Function Application_PreNavigate (DestViewName As String, DestBusObjName As String) 
As Integer
     Dim cmd As String
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     Dim oActionBO As BusObject
     Dim vtsBC As BusComp
     Dim spid As String
     Const appName = "Siebel Sales Enterprise"
     On Error Resume Next Set oActionBO = theApplication.GetBusObject("VTS_SPID") 
Set vtsBC = oActionBO.GetBusComp("VTS_SPID")
With vtsBC
     ClearToQuery
     ActivateField "Row Id"
     ExecuteQuery ForwardOnly
     FirstRecord
     i = .GetFieldValue("Row Id")
End With
     Set oActionBO = Nothing
     Set vtsBC = Nothing
     cmd = "vrts_srf_agent.exe " + i + " """ + appName + """ """ + DestViewName + 
""" """ + DestBusObjName + """ """ + LoginName + """"
     Shell(cmd)
     Application_PreNavigate = ContinueOperation
End Function 
If the Scripting Language in use is eScript, use the following script:
function Application_PreNavigate (DestViewName, DestBusObjName)
{
     try
     {
               var cmd;
               var oActionBO;
               var vtsBC;
               var appName = "Siebel Sales Enterprise";
               oActionBO = TheApplication().GetBusObject("VTS_SPID");
               vtsBC = oActionBO.GetBusComp("VTS_SPID");
               vtsBC.ClearToQuery();
               vtsBC.ActivateField("Row Id");
               vtsBC.ExecuteQuery(ForwardOnly);
               vtsBC.FirstRecord();
               cmd = "start cmd /c vrts_srf_agent.exe " +
               vtsBC.GetFieldValue("Row Id") +//SPID
               " \"" + appName +
               "\" \"" + DestViewName +
               "\" \"" + DestBusObjName +
               "\"\"" + TheApplication().LoginName() +
               "\"";
          vtsBC = null;
          oActionBO = null;
          Clib.system(cmd);
     }
     catch (obj)
     {
          Clib.system( "start cmd /c vrts_srf_agent.exe \"" + obj + "\"" );
          return (ContinueOperation); //Ignore all exceptions
     }
}
Modify the appName variable to match the name of the Siebel application.
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Replacing the table with a custom view (SQL Server)
The following procedure replaces the table with a custom view. To replace the table with a custom view

Log on to your Siebel database using Query Analyzer. Make sure to log on with a privileged account.
Run the following script:
     DROP TABLE CX_VTSSPID
     GO
     CREATE VIEW [CX_VTSSPID] as select
          '1' as [CONFLICT_ID],
          getdate() as [CREATED],
          '--' as [CREATED_BY],
          getdate() as [LAST_UPD],
          '2' as [LAST_UPD_BY],
          1 as [MODIFICATION_NUM],
          @@spid as [ROW_ID]
     GO
     GRANT SELECT ON [CX_VTSSPID] TO public
     GO

Completing the modification (SQL Server)
The following procedure completes the modification.

To complete the modification

Save all changes.
Compile the Siebel project. This will create a new Siebel.srf file.
Test the project on your development machine.
On each of your production Siebel Servers:

Stop the Siebel Server.
Deploy the new Siebel.srf file
Verify that the EnableScripting option in the application CFG file is set to TRUE.
Start the Siebel Server.

Debugging the script (SQL Server)
The following procedure debugs the script.

To debug the script

Before attempting to debug, from the View menu, select Options.
On the Debug file tab, open the file that is specified in the CFG file text box in a text editor.
Make sure that the RepositoryFile and ApplicationName options are set correctly.
Make sure the EnableScripting option is set to TRUE.

About sampling Siebel batch processes (Oracle)
For Siebel batch processes to be sampled by the Interpoint for Siebel Collectors, create a tab-delimited text file that 
contains the mapping of each Siebel server to its host machine, as it appears in Oracle.

To create the text file:

Log on to the server where your Siebel AppTier Collector instance is installed.
Create the following tab-delimited text file:
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Windows 
<Precise_root>\products\oracle\<SID>\etc\siebel_machines.txt
UNIX 
<Precise_root>/products/oracle/<SID>/etc/siebel_machines.txt

To obtain the list of Siebel servers:

Log on to the SrvrMgr utility.
Execute the following command:
list servers

The following list is an example of the results:

Table 1 List of Siebel servers

SBLSRVR_NAME HOST_NAME

AsDev1 POOL-SIEBEL1

AsDev2 POOL-SIEBEL2

Each returned row represents a Siebel server. The row information can be split into two columns:

The first column, SBLSRVR_NAME represents the name of the Siebel server, for example AsDev1.
The second column HOST_NAME represents the corresponding physical machine name, but not necessary as 
it appears in Oracle.

To find the physical machine name as it appears in Oracle, connect to the Siebel database and execute the 
following command:

SELECT DISTINCT MACHINE FROM V$SESSION;

The following list is an example of the results:

Table 2 Machine name list

MACHINE

PRECISE\POOL-SIEBEL1

PRECISE\POOL-SIEBEL2

If there is no entry in V$SESSION with the physical machine name, use the results from the HOST_NAME column. 
After inserting the previous results into the siebel_machines.txt file, the contents is as follows:

AsDev1 PRECISE\POOL-SIEBEL1

   AsDev2 PRECISE\POOL-SIEBEL2

Modifying the Siebel Repository File (Oracle)
Once the Siebel AppTier Collectors are installed, modify the Siebel Repository File (SRF), so that Interpoint for 
Siebel will be able to receive notifications of Siebel-related user events.

Part of the .srf file, is a collection of callback scripts, which are triggered by various events in a user's session. A user 
can view or change these scripts using the Siebel Tools.

For each targeted Siebel application, modify the .srf file on the Siebel server. Define the application name by 
hard coding it in the Application_PreNavigate function.
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The modified SRFs need to be distributed to each of the Siebel servers

If you have installed Interpoint for an Oracle database, modifying the SRF consists of the following tasks:

Creating the Precise Interpoint project (Oracle)
Creating the CX_PSS_SBL table (Oracle)
Creating the business component (Oracle)
Creating the business object (Oracle)
Adding the Application_PreNavigate() function (Oracle)
Replacing the table with a global temporary table (Oracle)
Completing the modification (Oracle)
Debugging the script (Oracle)

Creating the Precise Interpoint project (Oracle)
Open Siebel Tools.
In the Siebel Tools, on the Types tab in the Object Explorer, select Project.
Create a new project by pressing Ctrl+n.
Name the new project, "Precise Interpoint."
Lock the project, by choosing the Locked column to the right option.

Creating the CX_PSS_SBL table (Oracle)

From the File menu, choose New Object. The New Object Wizard opens.
On the General tab, select Table.

All objects created in subsequent steps will be grouped under this project.

This procedure includes some steps for versions up to version 8.0, and other steps for version 8.0 and 
higher. For steps where there are differences between versions, the difference has been clearly specified.
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Click OK. The General dialog box opens.
Figure 1 General Dialog Box

In the Enter a name for the new Table field, type CX_PSS_SBL.
From the Choose a Project in which you wish to create the Table drop-down list, select Precise Interpoint.
Under Select the type of the Table, select A stand-alone Table.
Click Next.
Click Finish to close the dialog box.
For versions prior to version 8.0, in the Tables workspace, click Apply. For version 8.0 and higher, in the 
Tables workspace, click Apply/DDL. In the displayed dialog box, click Apply.
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The Apply Schema dialog box is displayed.
Figure 2 Apply Schema dialog box

If needed, type a valid privileged user ID and privileged user password into the relevant text boxes.
Click Apply. The dialog box closes and the table is created.
In the Tables panel, click Activate to activate the new table.
In Siebel Tools, on the Types tab in the Object Explorer, select Table. The Tables panel opens.
Select table CX_PSS_SBL.
On the Types tab in the Object Explorer, Expand Tables and select Column. The Columns panel opens.
From the Edit menu, choose New Record. A new record is added to the table in the Columns panel.
Add two new columns to the table as follows:
Table 3 Table with new columns

Name User Name Physical Type Length

CLIENT_INFO Client Info Varchar 64
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Name User Name Physical Type Length

ACTION Action Varchar 32

For versions prior to version 8.0, in the Tables workspace, click Apply. For version 8.0 and higher, in the 
Tables workspace, click Apply/DDL. In the displayed dialog box, click Apply. The Apply Schema dialog box is 
displayed (see Figure 2).
If needed, type a valid privileged user ID and privileged user password into the relevant text boxes.
Click Apply. The dialog box closes and the records are created.
In the Tables panel, click Activate to activate the table with the new columns.
Figure 3 Siebel Repository - Column List Dialog Box

Creating the business component (Oracle)
In Siebel Tools, from the File menu, choose New Object. The New Object Wizard opens.
On the General tab, select BusComp.
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Click OK. The New Business Component dialog box opens.
Figure 4 New Business Component Dialog Box

In the Enter a name for the new Business Component field, type PRECISE_SBL.
From the Select the Project this Business Component will be part of drop-down list, select Precise 
Interpoint.
From the Select the Table this Business Component will operate on drop-down list, select CX_PSS_SBL.
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Click Next. The Single Value Fields dialog box opens.
Figure 5 Single Value Fields Dialog Box

From the Select a column in the Base table drop-down list, select ACTION. A default field name 
automatically appears in the Enter a name for the Field text box.
Click Add to move the selected row to the table.
From the Select a column in the Base table drop-down list, select CLIENT_INFO. A default field name 
automatically appears in the Enter a name for the Field text box.
Click Add to move the selected row to the table.
Click Finish to create the Business Component.

Creating the business object (Oracle)
In Siebel Tools, on the Types tab in the Object Explorer, select Business Object. The Business Objects panel 
opens.
From the Edit menu, choose New Record. A new record is added to the table in the Business Objects panel.
In the Name column, type PRECISE_SBL.
In the Project column, assign the new record to the Precise Interpoint project.
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On the Types tab in the Object Explorer, select Business Object > Business Object Component.
Figure 6 Siebel Repository - Business Object Component List Dialog Box

From the Edit menu, choose New Record. A new record is added to the table in the Business Object 
Components Panel.
In the Bus Comp column, type PRECISE_SBL.
From the Tools menu, choose Compile Project.

Adding the Application_PreNavigate() function (Oracle)
In Siebel Tools, from the View menu, select Options. On the Scripting tab, note the value of the Scripting 
Language list. If no language is selected, select the eScript option.
Figure 7 Development Tools Options Dialog Box
For versions prior to version 8.0:
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For version 8.0 and higher:
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In the Object Explorer, on the Types tab, expand Application.
Right-click on the application to be modified and select Lock Object.
Right-click on the application to be modified and select Edit Server Scripts.
In the Server Script Editor, select the Application_PreNavigate function. The function's default script 
appears in the text panel.
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Figure 8 Siebel Repository - Application [Siebel Sales Enterprise] - Script Dialog Box

If the used Scripting Language is eScript, use the following script:

Function Application_PreNavigate (DestViewName, DestBusObjName)
{
     try
     {
          var    oActionBO;
          var    pssBC;
          var    appName = "Siebel Sales Enterprise";
          var    action; //(32)
          var    client_info; //(64)

      
     oActionBO =
          TheApplication().GetBusObject("PRECISE_SBL");
               pssBC = oActionBO.GetBusComp("PRECISE_SBL");

      
               action = DestViewName.substring(0,32);

If this function already contains a custom script, do not continue. Contact Precise Technical 
Support for alternative instructions.



Modify the appName variable to match the name of the Siebel application.
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          client_info="S," +
          TheApplication().LoginName().substring(0,14) + "," +
               DestBusObjName.substring(0,31) + "," +
               appName.substring(0,17);

      
               pssBC.NewRecord(1);
          pssBC.SetFieldValue("Action", action);
               pssBC.SetFieldValue("Client Info", client_info);
               pssBC.WriteRecord();
               
               pssBC = null;
               oActionBO = null;
     }
     catch (obj)
     {
          pssBC = null;
          oActionBO = null;
          var sText = obj.errText;
          var nCode = obj.errCode;
     }
     finally
     {
          return (ContinueOperation);
     }
}
If the used Scripting Language is Visual Basic, use the following script:

Function Application_PreNavigate (DestViewName As String, DestBusObjName As String) 
As Integer
     Dim    oActionBO As BusObject
     Dim    pssBC As BusComp
     Dim    action As String
     Dim    client_info As String
     Const appName = "Siebel Field Service"

      
     On Error Resume Next
     Set oActionBO = TheApplication.GetBusObject("PRECISE_SBL")
     Set pssBC = oActionBO.GetBusComp("PRECISE_SBL")

      
     action = Left(DestViewName,32)
     client_info="S," + Left(LoginName,14) + "," + Left(DestBusObjName,31) + "," + 
Left(appName,17)

      
     pssBC.NewRecord 1
     pssBC.SetFieldValue "Action", action
     pssBC.SetFieldValue "Client Info", client_info

Modify the appName variable to match the name of the Siebel application.
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     pssBC.WriteRecord
     Set oActionBO = Nothing
     Set pssBC = Nothing

      
     Application_PreNavigate = ContinueOperation
End Function
Compile the project.

Replacing the table with a global temporary table (Oracle)
Log in to your Siebel database, using SQLPLUS. Make sure to log in with a privileged account.
Run the following statement:
create table CX_PSS_SBL_TAB as select * from CX_PSS_SBL where 1=2;
Drop the following table:
DROP TABLE CX_PSS_SBL;
Set the following grant for the table:
GRANT SELECT, INSERT, UPDATE, DELETE ON CX_PSS_SBL_TAB to SSE_ROLE;
Create the following view:
create view CX_PSS_SBL as
Select * from CX_PSS_SBL_TAB;
Set the following grant for the view:
GRANT SELECT, INSERT, UPDATE, DELETE ON CX_PSS_SBL TO SSE_ROLE;
Create the following trigger:
CREATE OR REPLACE TRIGGER CX_PSS_SBL_TRG
INSTEAD OF INSERT on CX_PSS_SBL
BEGIN
DBMS_APPLICATION_INFO.SET_CLIENT_INFO (:new.client_info); 
DBMS_APPLICATION_INFO.SET_ACTION (:new.action);
END;
/

Completing the modification (Oracle)
Save all changes.
Compile the Siebel project. This will create a new Siebel.srf file.
Test the project on your development machine.
On each of your production Siebel Servers:

Stop the Siebel Server.
Deploy the new Siebel.srf file
Verify that the EnableScripting option in the application CFG file is set to TRUE.
Start the Server.

Debugging the script (Oracle)
Before attempting to debug, select Options from the View menu.
Click the Debug file tab.
Note the file specified in the CFG file field and open it in a text editor.
Make sure the RepositoryFile and ApplicationName options are set correctly.
Make sure the EnableScripting option is set to TRUE.
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Uninstall action items
This section contains the following topics

Detailed Action Items for Siebel
Action items when Interpoint is installed on Oracle
Action items when Interpoint is installed on SQL Server

Detailed Action Items for Siebel
When the Siebel AppTier Collectors have been removed, you can delete the Precise Interpoint Project from the 
Siebel Repository File (SRF). These tasks differ slightly depending on whether Interpoint is installed for a SQL Server 
or an Oracle database. See Action items when Interpoint is installed on Oracle and Action items when Interpoint is 
installed on SQL Server.

Action items when Interpoint is installed on Oracle
Deleting this project from the SRF involves the following tasks:

Removing changes in the Application_PreNavigate() function (Oracle)
Removing the Business Object (Oracle)
Removing the CX_VTS_SBL table (Oracle)
Removing the Precise project (Oracle)

Removing changes in the Application_PreNavigate() function (Oracle)
To remove changes in the Application_PreNavigate() function

Make sure that you are able to view the Application Server Scripts objects. To do so, go to View > Options.
In the Development Tools Options window, select the Object Explorer tab. Make sure the Application Server 
Script check box under Application is checked.
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3.

Figure 1 Development Tools Options Dialog Box

In the Siebel Tools, on the Types tab in the Object Explorer, select Application > Application Server Script.

If the Application Server Script has not been checked in the View Options of the Siebel Tools, you 
cannot see the objects on the Types tab in the Object Explorer.
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2.
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Mark the Application_PreNavigate line, and then on the Edit menu, choose Delete Record.
Figure 2 Siebel Repository - Application Server Script List Dialog Box

Removing the Business Object (Oracle)
In Siebel Tools, on the Types tab in the Object Explorer, select Business Object. The Business Object panel 
opens.
Select the Business Object called PRECISE_SBL.
On the Types tab in the Object Explorer, select Business Object > Business Object Component. The 
Business Object Component panel for the PRECISE_SBL Business Object opens.

After you delete the Server Script, you must reopen the Siebel Tools, in order to make other 
changes in your application.
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4.

5.

Right click the Business Object Component called PRECISE_SBL and choose Delete Record.
Figure 3 Siebel Repository - Business Object Component List Dialog Box

Remove the Business Object by right-clicking the PRECISE_SBL business object on the Business Object 
panel and choosing Delete Record.



Precise Interpoint for Siebel 

27

1.
2.
3.
4.
5.

6.

7.

8.

1.
2.
3.

Figure 4 Siebel Repository - Business Object Component List Dialog Box

Removing the CX_PSS_SBL table (Oracle)
In Siebel Tools, on the Types tab in the Object Explorer, select Table. The Tables panel opens.
Select the table called CX_PSS_SBL.
Right-click on the table and choose Delete Record.
Log in to the Siebel database with the Siebel user.
Run the following command:
select * from user_views where view_name = 'CX_PSS_SBL';
If you get a row as a reply, run the following command:
drop view CX_PSS_SBL;
Run the following command:
select * from user_tables where table_name = 'CX_PSS_SBL_TAB';
If you get a row as a reply, run the following command:
drop table CX_PSS_SBL_TAB;

Removing the project (Oracle)
In Siebel Tools, on the Types tab in the Object Explorer, select Project.
In the projects panel search for the Precise Interpoint project.
Make the project inactive.
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Action items when Interpoint is installed on SQL Server
Deleting this project from the SRF involves the following tasks:

Removing changes in the Application_PreNavigate() function (SQL Server)
Removing the Business Object (SQL Server)
Removing the CX_VTSSPID table (SQL Server)
Removing the Precise project (SQL Server)

Removing changes in the Application_PreNavigate() function (SQL Server)
To remove changes in the Application_PreNavigate() function

In Siebel Tools, go to View > Options.
In the Development Tools Options dialog box, on the Object Explorer tab, check Application Server 
Script to display this application on the Types tab in the Object Explorer.
In the Object Explorer, on the Types tab, go to Application > Application Server Script.
In the Application Server Scripts panel, select the script called Application_PreNavigate.
On the Edit menu, choose Delete Record.

If you want to make additional changes to your application, you first need to close and then reopen Siebel Tools.

Removing the Business Object (SQL Server)
To remove the business object

In Siebel Tools, in the Object Explorer, on the Types tab, select Business Object.
In the Business Object panel, select the Business Object called VTS_SPID.
On the Types tab, go to Business Object > Business Object Component. The Business Object Component 
panel for the VTS_SPID Business Object opens.
In the Business Object Component panel, right-click the component called VTS_SPID and select Delete 
Record.

Removing the CX_VTSSPID table (SQL Server)
To remove the CX_VTSSPID table

In Siebel Tools, in the Object Explorer, on the Types tab, select Table.
In the Table panel, right-click the table called CX_VTSSPID and select Delete Record.
Log on to the Siebel database with the Siebel user.
Run the following command:
select * from user_views where view_name = 'CX_VTSSPID';
If a row is returned, run the following command:
drop view CX_VTSSPID;
Run the following command:
select * from user_tables where table_name = 'CX_VTSSPID_TAB';
If a row is returned, run the following command:
drop table CX_VTSSPID_TAB;

Removing the project (SQL Server)
To remove the Precise Interpoint project

In Siebel Tools, in the Object Explorer, on the Types tab, select Project.
In the Projects panel, search for the Precise Interpoint project.
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3. Make the project inactive.
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