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Performing post-installation action items on a Siebel 
instance
This section includes the following topics:

About performing actions on a Siebel instance
Setting up Siebel batch process sampling
About sampling Siebel batch processes (SQL Server)
Modifying the Siebel Repository File (SQL Server)
About sampling Siebel batch processes (Oracle)
Modifying the Siebel Repository File (Oracle)

About performing actions on a Siebel instance

The Interpoint for Siebel extension of Precise for SQL Server and Precise for Oracle can only receive notifications of user events if specific objects are 
included in the Siebel Repository File (SRF). Before you can use Interpoint for Siebel, you need to modify the SRF file. This document describes how to 
add the required objects to the file.

Setting up Siebel batch process sampling

For Siebel batch processes to be sampled by the Siebel AppTier Collectors, you need to create a tab-delimited text file that contains the mapping of each 
Siebel server to its host machine and network address. Each row in the file represents a physical machine. The first field in each row should represent the 
name of the Siebel server, the second field its corresponding host machine name, and the third its network address.

About sampling Siebel batch processes (SQL Server)

If you have installed Interpoint for a SQL Server database, perform the following procedures.

To create the text file

Log on to the database server where your Siebel AppTier Collector is installed.
Create the following tab-delimited text file:
< >\products\sql-server\< >\etc\siebel_machines.txtPrecise_root instance_ name

To obtain the list of Siebel servers

Log on to the SrvrMgr utility.
Execute the following command:

 list servers
Each returned row represents a Siebel server.

To obtain the host machine name and network address

Copy the getAddress.vbs script from the Utilities\Siebel directory on the installation DVD to the server.
Run the following command:
cscript //nologo getAddress.vbs ODBC data source

 Administrator user name Administrator passwords
where ODBC data source is the name of the ODBC data source used by the Siebel server to connect to SQL Server. To determine its name, 
check the ConnectString value in the siebel.cfg configuration file.

 and  are the user name and password required to connect to the SQL Server instance.Administrator user name Administrator password
Repeat these steps for each Siebel server.

Following is an example for the content of the siebel_machines.txt file:

sieb1 APPSRV1 00096B26E66C
sieb2 APPSRV2 00096B26E67C

Modifying the Siebel Repository File (SQL Server)

Once the Siebel AppTier Collectors are installed, modify the Siebel Repository File (SRF), so that Interpoint for Siebel will be able to receive notifications of 
Siebel-related user events.

Part of the .srf file, is a collection of callback scripts, which are triggered by various events in a user's session. A user can view or change these scripts 
using the Siebel Tools.

For each targeted Siebel application, modify the .srf file on the Siebel server. Define the application name by hard coding it in the 
Application_PreNavigate function.
The modified SRFs need to be distributed to each of the Siebel servers

If you have installed Interpoint for Siebel for a SQL Server database, modifying the SRF consists of the following tasks:

Creating the Precise Interpoint project (SQL Server)
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Creating the CX_VTSSPID table (SQL Server)
Creating the business component (SQL Server)
Creating the business object (SQL Server)
Adding the Application_PreNavigate() function (SQL Server)
Replacing the table with a custom view (SQL Server)
Completing the modification (SQL Server)
Debugging the script (SQL Server)

Creating the Precise Interpoint project (SQL Server)

The following procedure creates the VERITAS Interpoint project. All objects created in the procedures following on this procedure will be grouped under 
this project.

To create the Interpoint project

Open Siebel Tools.
In the Object Explorer, on the Types tab, select .Project
Create a new project by pressing Ctrl+n.
Name the new project, "Precise Interpoint."
Lock the project by clicking the  column to the right.Locked

Creating the CX_VTSSPID table (SQL Server)

The following procedure creates a table in the DBMS.

To create the CX_VTSSPID table

From the File menu, select .New Object
In the New Object Wizard, on the General tab, select ; then click .Table OK
In the General dialog box, do the following:

In the Enter a name for the new Table text box, type .CX_VTSSPID
From the Choose a Project in which you wish to create the Table list, select .Precise Interpoint
Under Select the type of the Table, select .A stand-alone Table

Click ; then click  to close the dialog box.Next Finish
In the Tables workspace, click .Apply
In the Apply Schema dialog box, if needed, type a valid privileged user ID and privileged user password into the relevant text boxes.
Click . The dialog box closes, and the table is created.Apply
In the Tables panel, click  to activate the new table.Activate

Creating the business component (SQL Server)

The following procedure creates the VTS_SPID business component.

To create the business component

In Siebel Tools, from the File menu, select . The New Object Wizard opens.New Object
On the General tab, select .BusComp
Click .OK
In the New Business Component dialog box, do the following:

In the Enter a name for the new Business Component text box, type .VTS_SPID
From the Select the Project this Business Component will be part of list, select .Precise Interpoint
From the Select the Table this Business Component will operate on list, select .CX_VTSSPID

Click .Next
In the Single Value Fields dialog box, from the Select a column in the Base table list, select . A default Field name automatically appears ROW_ID
in the Enter a name for the Field text box.
Click  to move the selected row to the table; then click  to create the business component.Add Finish

Creating the business object (SQL Server)

The following procedure creates the VTS_SPID business object.

To create the business object

In Siebel Tools, in the Objects Explorer, on the Types tab, select .Business Object
In the Business Objects panel, from the Edit menu, select . A new record is added to the table in the Business Objects panel.New Record
In the Name column, type: .VTS_SPID
In the Project column, assign the new record to the VERITAS Interpoint project.
On the Types tab in the Object Explorer, select Business Object > Business Object Component.
From the Edit menu, select . A new record is added to the table in the Business Object Components panel.New Record
In the BusComp column, type: .VTS_SPID
From the Tools menu, select .Compile Project

Adding the Application_PreNavigate() function (SQL Server)

The following procedure adds the Application_PreNavigate() function.
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To add the Application_PreNavigate() function

In Siebel Tools, from the View menu, select .Options
In the Development Tools Options dialog box, on the Scripting tab, note the value of the Scripting Language list and click .OK
In the Object Explorer, on the Types tab, expand Application.
Right-click on the application to be modified and select .Lock Object
Right-click on the application to be modified and select .Edit Server Scripts
In the Server Script Editor, select the  function. The function's default script appears in the text panel.Application_PreNavigate
If this function already contains a custom script, contact Precise Customer Support for alternative instructions.
Replace the default script with the following script:
Function Application_PreNavigate (DestViewName As String, DestBusObjName As String) As Integer
     Dim cmd As String
     Dim oActionBO As BusObject
     Dim vtsBC As BusComp
     Dim spid As String
     Const appName = "Siebel Sales Enterprise"
     On Error Resume Next Set oActionBO = theApplication.GetBusObject("VTS_SPID") Set vtsBC = oActionBO.
GetBusComp("VTS_SPID")
With vtsBC
     ClearToQuery
     ActivateField "Row Id"
     ExecuteQuery ForwardOnly
     FirstRecord
     i = .GetFieldValue("Row Id")
End With
     Set oActionBO = Nothing
     Set vtsBC = Nothing
     cmd = "vrts_srf_agent.exe " + i + " """ + appName + """ """ + DestViewName + """ """ + DestBusObjName 
+ """ """ + LoginName + """"
     Shell(cmd)
     Application_PreNavigate = ContinueOperation

 End Function
If the Scripting Language in use is eScript, use the following script:
function Application_PreNavigate (DestViewName, DestBusObjName)
{
     try
     {
               var cmd;
               var oActionBO;
               var vtsBC;
               var appName = "Siebel Sales Enterprise";
               oActionBO = TheApplication().GetBusObject("VTS_SPID");
               vtsBC = oActionBO.GetBusComp("VTS_SPID");
               vtsBC.ClearToQuery();
               vtsBC.ActivateField("Row Id");
               vtsBC.ExecuteQuery(ForwardOnly);
               vtsBC.FirstRecord();
               cmd = "start cmd /c vrts_srf_agent.exe " +
               vtsBC.GetFieldValue("Row Id") +//SPID
               " \"" + appName +
               "\" \"" + DestViewName +
               "\" \"" + DestBusObjName +
               "\"\"" + TheApplication().LoginName() +
               "\"";
          vtsBC = null;
          oActionBO = null;
          Clib.system(cmd);
     }
     catch (obj)
     {
          Clib.system( "start cmd /c vrts_srf_agent.exe \"" + obj + "\"" );
          return (ContinueOperation); //Ignore all exceptions
     }
}
Modify the appName variable to match the name of the Siebel application.

Replacing the table with a custom view (SQL Server)

The following procedure replaces the table with a custom view. To replace the table with a custom view

Log on to your Siebel database using Query Analyzer. Make sure to log on with a privileged account.
Run the following script:
     DROP TABLE CX_VTSSPID
     GO
     CREATE VIEW [CX_VTSSPID] as select
          '1' as [CONFLICT_ID],
          getdate() as [CREATED],
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          '--' as [CREATED_BY],
          getdate() as [LAST_UPD],
          '2' as [LAST_UPD_BY],
          1 as [MODIFICATION_NUM],
          @@spid as [ROW_ID]
     GO
     GRANT SELECT ON [CX_VTSSPID] TO public
     GO

Completing the modification (SQL Server)

The following procedure completes the modification.

To complete the modification

Save all changes.
Compile the Siebel project. This will create a new Siebel.srf file.
Test the project on your development machine.
On each of your production Siebel Servers:

Stop the Siebel Server.
Deploy the new Siebel.srf file
Verify that the EnableScripting option in the application CFG file is set to TRUE.
Start the Siebel Server.

Debugging the script (SQL Server)

The following procedure debugs the script.

To debug the script

Before attempting to debug, from the View menu, select .Options
On the Debug file tab, open the file that is specified in the CFG file text box in a text editor.
Make sure that the RepositoryFile and ApplicationName options are set correctly.
Make sure the EnableScripting option is set to TRUE.

About sampling Siebel batch processes (Oracle)

For Siebel batch processes to be sampled by the Interpoint for Siebel Collectors, create a tab-delimited text file that contains the mapping of each Siebel 
server to its host machine, as it appears in Oracle.

To create the text file:

Log on to the server where your Siebel AppTier Collector instance is installed.
Create the following tab-delimited text file:

Windows 
< >\products\oracle\<SID>\etc\siebel_machines.txtPrecise_root
UNIX 
< >/products/oracle/<SID>/etc/siebel_machines.txtPrecise_root

To obtain the list of Siebel servers:

Log on to the SrvrMgr utility.
Execute the following command:
list servers

The following list is an example of the results:

Table 1 List of Siebel servers

SBLSRVR_NAME HOST_NAME

AsDev1 POOL-SIEBEL1

AsDev2 POOL-SIEBEL2

Each returned row represents a Siebel server. The row information can be split into two columns:

The first column,  represents the name of the Siebel server, for example .SBLSRVR_NAME AsDev1
The second column  represents the corresponding physical machine name, but not necessary as it appears in Oracle.HOST_NAME

To find the physical machine name as it appears in Oracle, connect to the Siebel database and execute the following command:

SELECT DISTINCT MACHINE FROM V$SESSION;

The following list is an example of the results:



1.  
2.  
3.  
4.  
5.  

1.  
2.  

Table 2 Machine name list

MACHINE

PRECISE\POOL-SIEBEL1

PRECISE\POOL-SIEBEL2

If there is no entry in  with the physical machine name, use the results from the  column. After inserting the previous results into V$SESSION HOST_NAME
the  file, the contents is as follows:siebel_machines.txt

AsDev1 PRECISE\POOL-SIEBEL1
AsDev2 PRECISE\POOL-SIEBEL2

Modifying the Siebel Repository File (Oracle)

Once the Siebel AppTier Collectors are installed, modify the Siebel Repository File (SRF), so that Interpoint for Siebel will be able to receive notifications of 
Siebel-related user events.

Part of the .srf file, is a collection of callback scripts, which are triggered by various events in a user's session. A user can view or change these scripts 
using the Siebel Tools.

For each targeted Siebel application, modify the .srf file on the Siebel server. Define the application name by hard coding it in the 
Application_PreNavigate function.
The modified SRFs need to be distributed to each of the Siebel servers

If you have installed Interpoint for an Oracle database, modifying the SRF consists of the following tasks:

Creating the Precise Interpoint project (Oracle)
Creating the CX_PSS_SBL table (Oracle)
Creating the business component (Oracle)
Creating the business object (Oracle)
Adding the Application_PreNavigate() function (Oracle)
Replacing the table with a global temporary table (Oracle)
Completing the modification (Oracle)
Debugging the script (Oracle)

Creating the Precise Interpoint project (Oracle)

Open Siebel Tools.
In the Siebel Tools, on the Types tab in the Object Explorer, select .Project
Create a new project by pressing Ctrl+n.
Name the new project, "Precise Interpoint."
Lock the project, by choosing the  column to the right option.Locked

Creating the CX_PSS_SBL table (Oracle)

From the File menu, choose . The New Object Wizard opens.New Object
On the General tab, select .Table

All objects created in subsequent steps will be grouped under this project.

This procedure applies to versions up to version 8.0 and version 8.0 and higher. For steps where there are differences between versions, the 
difference has been clearly specified.
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Click . The General dialog box opens.OK
 General Dialog BoxFigure 1

In the Enter a name for the new Table field, type .CX_PSS_SBL
From the Choose a Project in which you wish to create the Table drop-down list, select .Precise Interpoint
Under Select the type of the Table, select .A stand-alone Table
Click .Next
Click  to close the dialog box.Finish
For versions prior to version 8.0, in the Tables workspace, click . For version 8.0 and higher, in the Tables workspace, click . In Apply Apply/DDL
the displayed dialog box, click .Apply
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The Apply Schema dialog box is displayed.
 Apply Schema dialog boxFigure 2

If needed, type a valid privileged user ID and privileged user password into the relevant text boxes.
Click . The dialog box closes and the table is created.Apply
In the Tables panel, click  to activate the new table.Activate
In Siebel Tools, on the Types tab in the Object Explorer, select . The Tables panel opens.Table
Select table .CX_PSS_SBL
On the Types tab in the Object Explorer, Expand Tables and select . The Columns panel opens.Column
From the Edit menu, choose . A new record is added to the table in the Columns panel.New Record
Add two new columns to the table as follows:

 Table with new columnsTable 3

Name User Name Physical Type Length

CLIENT_INFO Client Info Varchar 64

ACTION Action Varchar 32

For versions prior to version 8.0, in the Tables workspace, click . For version 8.0 and higher, in the Tables workspace, click . In Apply Apply/DDL
the displayed dialog box, click . The Apply Schema dialog box is displayed (see Figure 1-2).Apply
If needed, type a valid privileged user ID and privileged user password into the relevant text boxes.
Click . The dialog box closes and the records are created.Apply
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In the Tables panel, click  to activate the table with the new columns.Activate
 Siebel Repository - Column List Dialog BoxFigure 3

Creating the business component (Oracle)

In Siebel Tools, from the File menu, choose . The New Object Wizard opens.New Object
On the General tab, select .BusComp
Click . The New Business Component dialog box opens.OK

 New Business Component Dialog BoxFigure 4

In the Enter a name for the new Business Component field, type .PRECISE_SBL
From the Select the Project this Business Component will be part of drop-down list, select .Precise Interpoint
From the Select the Table this Business Component will operate on drop-down list, select .CX_PSS_SBL
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Click . The Single Value Fields dialog box opens.Next
 Single Value Fields Dialog BoxFigure 5

From the Select a column in the Base table drop-down list, select . A default field name automatically appears in the Enter a name for the ACTION
Field text box.
Click  to move the selected row to the table.Add
From the Select a column in the Base table drop-down list, select . A default field name automatically appears in the Enter a name CLIENT_INFO
for the Field text box.
Click  to move the selected row to the table.Add
Click  to create the Business Component.Finish

Creating the business object (Oracle)

In Siebel Tools, on the Types tab in the Object Explorer, select . The Business Objects panel opens.Business Object
From the Edit menu, choose . A new record is added to the table in the Business Objects panel.New Record
In the Name column, type .PRECISE_SBL
In the Project column, assign the new record to the Precise Interpoint project.
On the Types tab in the Object Explorer, select Business Object > Business Object Component.

 Siebel Repository - Business Object Component List Dialog BoxFigure 6

From the Edit menu, choose . A new record is added to the table in the Business Object Components Panel.New Record
In the Bus Comp column, type .PRECISE_SBL
From the Tools menu, choose .Compile Project

Adding the Application_PreNavigate() function (Oracle)
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In Siebel Tools, from the View menu, select . On the Scripting tab, note the value of the Scripting Language list. If no language is Options
selected, select the  option.eScript

 Development Tools Options Dialog BoxFigure 7
For versions prior to version 8.0:

 
For version 8.0 and higher:

In the Object Explorer, on the Types tab, expand .Application
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Right-click on the application to be modified and select .Lock Object
Right-click on the application to be modified and select .Edit Server Scripts
In the Server Script Editor, select the  function. The function's default script appears in the text panel.Application_PreNavigate

 Siebel Repository - Application [Siebel Sales Enterprise] - Script Dialog BoxFigure 8

If the used Scripting Language is eScript, use the following script:

Function Application_PreNavigate (DestViewName, DestBusObjName)
{
     try
     {
          var    oActionBO;
          var    pssBC;
          var    appName = "Siebel Sales Enterprise";
          var    action; //(32)
          var    client_info; //(64)

     oActionBO =
          TheApplication().GetBusObject("PRECISE_SBL");
               pssBC = oActionBO.GetBusComp("PRECISE_SBL");

               action = DestViewName.substring(0,32);
          client_info="S," +
          TheApplication().LoginName().substring(0,14) + "," +
               DestBusObjName.substring(0,31) + "," +
               appName.substring(0,17);

               pssBC.NewRecord(1);
          pssBC.SetFieldValue("Action", action);
               pssBC.SetFieldValue("Client Info", client_info);
               pssBC.WriteRecord();
               
               pssBC = null;
               oActionBO = null;
     }
     catch (obj)
     {
          pssBC = null;
          oActionBO = null;
          var sText = obj.errText;

If this function already contains a custom script, do not continue. Contact Precise Technical Support for alternative instructions.

Modify the appName variable to match the name of the Siebel application.
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          var nCode = obj.errCode;
     }
     finally
     {
          return (ContinueOperation);
     }
}
If the used Scripting Language is Visual Basic, use the following script:

Function Application_PreNavigate (DestViewName As String, DestBusObjName As String) As Integer
     Dim    oActionBO As BusObject
     Dim    pssBC As BusComp
     Dim    action As String
     Dim    client_info As String
     Const appName = "Siebel Field Service"

     On Error Resume Next
     Set oActionBO = TheApplication.GetBusObject("PRECISE_SBL")
     Set pssBC = oActionBO.GetBusComp("PRECISE_SBL")

     action = Left(DestViewName,32)
     client_info="S," + Left(LoginName,14) + "," + Left(DestBusObjName,31) + "," + Left(appName,17)

     pssBC.NewRecord 1
     pssBC.SetFieldValue "Action", action
     pssBC.SetFieldValue "Client Info", client_info
     pssBC.WriteRecord
     Set oActionBO = Nothing
     Set pssBC = Nothing

     Application_PreNavigate = ContinueOperation
End Function
Compile the project.

Replacing the table with a global temporary table (Oracle)

Log in to your Siebel database, using SQLPLUS. Make sure to log in with a privileged account.
Run the following statement:
create table CX_PSS_SBL_TAB as select * from CX_PSS_SBL where 1=2;
Drop the following table:
DROP TABLE CX_PSS_SBL;
Set the following grant for the table:
GRANT SELECT, INSERT, UPDATE, DELETE ON CX_PSS_SBL_TAB to SSE_ROLE;
Create the following view:
create view CX_PSS_SBL as
Select * from CX_PSS_SBL_TAB;
Set the following grant for the view:
GRANT SELECT, INSERT, UPDATE, DELETE ON CX_PSS_SBL TO SSE_ROLE;
Create the following trigger:
CREATE OR REPLACE TRIGGER CX_PSS_SBL_TRG
INSTEAD OF INSERT on CX_PSS_SBL
BEGIN
DBMS_APPLICATION_INFO.SET_CLIENT_INFO (:new.client_info); DBMS_APPLICATION_INFO.SET_ACTION (:new.action);
END;
/

Completing the modification (Oracle)

Save all changes.
Compile the Siebel project. This will create a new Siebel.srf file.
Test the project on your development machine.
On each of your production Siebel Servers:

Stop the Siebel Server.
Deploy the new Siebel.srf file
Verify that the EnableScripting option in the application CFG file is set to TRUE.
Start the Server.

Debugging the script (Oracle)

Before attempting to debug, select  from the View menu.Options
Click the Debug file tab.

Modify the appName variable to match the name of the Siebel application.
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Note the file specified in the CFG file field and open it in a text editor.
Make sure the RepositoryFile and ApplicationName options are set correctly.
Make sure the EnableScripting option is set to TRUE.
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